Symptoms
- The ESXi host appears as disconnected in vCenter Server
- Attempting to reconnect the host fails
- You see the error:
A general system error occured: Timed waiting for vpxa to start
Cause
This issue occurs if one or more virtual machines on the host are running on a large number of snapshots. The maximum number of snapshots supported is 32. For more information, see Best practices for virtual machine snapshots in the VMware environment (1025279).
Resolution
To resolve this issue:
- Remove the virtual machine from the vCenter Server Inventory.
- Restart the Management agents on host. For more information, see Restarting the Management agents on an ESX or ESXi host (1003490).
- Log in to the host directly using the vSphere Client.
- Right-click the virtual machine and click Remove from Inventory.
- Restart the Management agents on the host.
- Right-click the host in vCenter Server and click Reconnect.
Based on VMware KB 2031936
